Bilun í aðgerðum í gáttum
Incident Report for Sjúkratryggingar
Resolved
This incident has been resolved.
Posted May 12, 2022 - 13:23 UTC
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 09:59 UTC
Investigating
We are currently investigating this issue.
Posted May 12, 2022 - 09:48 UTC
This incident affected: Þjónustusíður (Réttindagátt, Gagnagátt).