Bilun í netsambandi
Incident Report for Sjúkratryggingar
Resolved
This incident has been resolved.
Posted Nov 24, 2021 - 02:02 UTC
Investigating
We are currently investigating this issue.
Posted Nov 24, 2021 - 01:55 UTC
This incident affected: Vefþjónustur (Vefþjónustur varaleið).